Invalid CSRF token!XH-ERROR again.

A place to report and discuss bugs - please mention CMSimple-version, server, platform and browser version
Post Reply
Tata
Posts: 2690
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Invalid CSRF token!XH-ERROR again.

Post by Tata » Fri Mar 02, 2018 8:30 pm

After finishing templates creation with onepage plugin (now tested here), I tried to use the same templates without the plugin (now tested here). The templates work fine. Both webpages have exactly the same set of plugins.
In the "standard" version (without the onepage plugin) I can't save any change both in content or settings.
Invalid CSRF token!XH-ERROR: Invalid CSRF token!
/Users/msereday/webpages/rancdubina/cmsimple/classes/CSRFProtection.php:125
In the "onepage" version everything works fine except of the pagemanager. Where shall I look for a reason?
The only XH_debug warning is
WARNING: A non-numeric value encountered
/Users/msereday/webpages/rancdubina/cmsimple/functions.php:2661
But this is reported in both versions.
pagemanager-missnig-icons.jpg
You do not have the required permissions to view the files attached to this post.
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

cmb
Posts: 12595
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Invalid CSRF token!XH-ERROR again.

Post by cmb » Sat Mar 03, 2018 12:53 pm

Tata wrote:
Fri Mar 02, 2018 8:30 pm
After finishing templates creation with onepage plugin (now tested here), I tried to use the same templates without the plugin (now tested here). The templates work fine. Both webpages have exactly the same set of plugins.
I guess there is a fatal error caused by the template. Have a look at the generated HTML, and see whether it terminates as desired (</html>) or not.
Tata wrote:
Fri Mar 02, 2018 8:30 pm
In the "onepage" version everything works fine except of the pagemanager. Where shall I look for a reason?
The only XH_debug warning is
WARNING: A non-numeric value encountered
/Users/msereday/webpages/rancdubina/cmsimple/functions.php:2661
Hm, that would be an empty line. :?
Tata wrote:
Fri Mar 02, 2018 8:30 pm
But this is reported in both versions.
I suggest to compare the generated HTML of both versions. If it is identical, the FontAwesome Fonts or CSS might be missing.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Tata
Posts: 2690
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: Invalid CSRF token!XH-ERROR again.

Post by Tata » Sat Mar 03, 2018 1:06 pm

Today the ERROR-WARNING is gone. Maybe OPCahce again involved.
The other warning was reallz caused by the additional empty line after the last ?> in functions.php.
Thanks a lot. Now all templates and pages work fine.
THX
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

Post Reply