XH 1.6.2 requires PHP 5

A place to report and discuss bugs - please mention CMSimple-version, server, platform and browser version
Post Reply
cmb
Posts: 13274
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

XH 1.6.2 requires PHP 5

Post by cmb » Sun Jun 15, 2014 8:53 pm

Hello Community,

Korvell noticed problems on loggin out, and it turned out that these are caused by cmsimple/classes/Backup.php not being PHP 4 compatible. Inadvertently, I've used the "private" keyword for the instance variables, which is allowed only since PHP 5. This causes a parse error on PHP 4, and results in a blank window. The undesired use of "private" slipped through PHP_CompatInfo, because of a bug that I have reported in the meantime.

I have made a patch available that contains the necessary replacement of cmsimple/classes/Backup.php.

Christoph

PS: I have furthermore checked for uses of "private" in the other files; everything else is fine.
Last edited by cmb on Sun Jun 15, 2014 8:57 pm, edited 1 time in total.
Reason: added PS
Christoph M. Becker – Plugins for CMSimple_XH

cmb
Posts: 13274
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: XH 1.6.2 requires PHP 5

Post by cmb » Mon Jul 14, 2014 8:36 pm

Done (r1317).
Christoph M. Becker – Plugins for CMSimple_XH

svasti
Posts: 1649
Joined: Wed Dec 17, 2008 5:08 pm

Re: XH 1.6.2 requires PHP 5

Post by svasti » Sat Aug 02, 2014 12:11 pm

Just had the same problem on the site of parken, which was php 4.4,
logout didn't work and the pagemanager also wouldn't open all pages.
Anyhow, problem solved on changing the server to php 5.4

cmb
Posts: 13274
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: XH 1.6.2 requires PHP 5

Post by cmb » Sat Aug 02, 2014 4:22 pm

svasti wrote:pagemanager also wouldn't open all pages.
Hm, do you mean the expand/collapse buttons didn't work? I'll have a look at it later.
svasti wrote:Anyhow, problem solved on changing the server to php 5.4
Great! Should also bring some performance improvements.
Christoph M. Becker – Plugins for CMSimple_XH

svasti
Posts: 1649
Joined: Wed Dec 17, 2008 5:08 pm

Re: XH 1.6.2 requires PHP 5

Post by svasti » Sat Aug 02, 2014 4:41 pm

cmb wrote:Hm, do you mean the expand/collapse buttons didn't work? I'll have a look at it later.
yes. Interesting, nobody complained about it. This means to me that users who are active in updating their system also take care to use an up-to-date php version. So we shouldn't meet any opposition on raising the minimum requirement php version to 5.2, which is still pretty low.

cmb
Posts: 13274
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: XH 1.6.2 requires PHP 5

Post by cmb » Sat Aug 02, 2014 4:56 pm

svasti wrote:
cmb wrote:Hm, do you mean the expand/collapse buttons didn't work? I'll have a look at it later.
yes.
Thanks for the fast confirmation. I had a quick look at it, and I'm suprised though, because no PHP is involved in the functionality. I suppose that the problem is related to http://cmsimpleforum.com/viewtopic.php?f=12&t=7902.
svasti wrote:Interesting, nobody complained about it. This means to me that users who are active in updating their system also take care to use an up-to-date php version. So we shouldn't meet any opposition on raising the minimum requirement php version to 5.2, which is still pretty low.
ACK, especially because PHP 7 seems to be on its way, and I'd rather avoid to support 3 major PHP versions.
Christoph M. Becker – Plugins for CMSimple_XH

Post Reply