plugin - zGallery problem

A place to report and discuss bugs - please mention CMSimple-version, server, platform and browser version
Post Reply
kurtm
Posts: 50
Joined: Tue Sep 03, 2013 12:29 am
Location: New Zealand

plugin - zGallery problem

Post by kurtm » Sat Aug 01, 2015 3:20 am

I use the zGallery plugin (1.20rc4 April 2012) to display photos in Lightbox manner.
On CMSimple_XH 1.6.1 (installed recently) everything works as designed only when I'm logged on (for maintenance) but as soon as I log out the code stops working. The images become static. (http://bell-radio-tv.info.org.nz/)
The problem exists on the latest Firefox, Chrome and IE so I have discounted the browser as the problem.
I have another site using CMSimple-XH 1.5. which works perfectly when I'm logged out. (http://www.danishsociety.org.nz/?ABOUT/ ... elebrating)
Any suggestions?

cmb
Posts: 13297
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: plugin - zGallery problem

Post by cmb » Sat Aug 01, 2015 9:44 am

Hi Kurt,

thanks for the link to the affected website. The JavaScript error console (F12 on most browsers) gives some hint:
Uncaught ReferenceError: jQuery is not defined
So it's probably sufficient to activate jQuery via Plugins → Jquery → Config → Autoload.
Christoph M. Becker – Plugins for CMSimple_XH

kurtm
Posts: 50
Joined: Tue Sep 03, 2013 12:29 am
Location: New Zealand

Re: plugin - zGallery problem

Post by kurtm » Mon Aug 03, 2015 12:26 am

Many thanks CMB - it worked !!

Now - how would I have known this answer without asking the question on this forum? I've been struggling with this problem for a while spending many hours experimenting with options and reinstalling zGallery and re-uploading files, etc., etc. On one site I changed to another plugin. I couldn't find anything about this in the install instructions.
Honestly, I'm a biggot for the use of CMSimple and I wouldn't use any other CMS because it's very simple and frankly, it does what I need for basic sites with a few glitzy features. Who would ask for anything more. But, I'd have to say that there are some gaps in the documentation which would have helped me. I'm volunteering time to CMSimple to help with the documentation if needed, let me know if I can help. However, the application programmers are really the ones who know the setup needs and operational requirements. You always solve my problems quickly so probably I need to ask for help quicker, but I don't want to take up your valuable time.

Many thanks again and keep up the good work, I know you are all volunteers without pay for this system.

My websites are also free to others and I'm a volunteer too.

Kurt

cmb
Posts: 13297
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: plugin - zGallery problem

Post by cmb » Mon Aug 03, 2015 11:28 am

The need to have jQuery enabled should be documented in the plugin's manual (aka. help file). I don't know who maintains zGallery (I once downloaded a copy from an Australian website, IIRC), but you may try to contact them.

If you want to help with the general CMSimple_XH documentation, you are very welcome. The XH Wiki certainly needs updates and improvements. I'll send you a PM with you account data.
Christoph M. Becker – Plugins for CMSimple_XH

kurtm
Posts: 50
Joined: Tue Sep 03, 2013 12:29 am
Location: New Zealand

Re: plugin - zGallery problem

Post by kurtm » Tue Aug 04, 2015 12:53 am

Got it thanks Christoph. Will take a little time to familiarise myself with the setup before making any updates.
Regarsds,
Kurt

cmb
Posts: 13297
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: plugin - zGallery problem

Post by cmb » Tue Aug 04, 2015 11:49 pm

kurtm wrote:Will take a little time to familiarise myself with the setup before making any updates.
Yes, of course. :) Feel free to ask any questions here in the forum or via PM/email to me.

As I understand it, you're speaking German. If so, you might be interested in translating Hartmut's CMSimple_XH documentation (or maybe parts of it), see http://cmsimplexh.webdesign-keil.de/. If you're interested contact Hartmut or me for the "master" documents.

And of course, all that is voluntary work, so there are no obligations in any way. :)
Christoph M. Becker – Plugins for CMSimple_XH

kurtm
Posts: 50
Joined: Tue Sep 03, 2013 12:29 am
Location: New Zealand

Re: plugin - zGallery problem

Post by kurtm » Wed Aug 05, 2015 1:35 am

Unfortunately - no German language other than using Bing or Google. But I do understand quite a lot. I am Danish.

cmb
Posts: 13297
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: plugin - zGallery problem

Post by cmb » Wed Aug 05, 2015 9:36 pm

kurtm wrote:Unfortunately - no German language other than using Bing or Google. But I do understand quite a lot. I am Danish.
I see! So if you like you could also work on the (barely started) Danish translation of the XH-Wiki. :)
Christoph M. Becker – Plugins for CMSimple_XH

Post Reply