Plugin Calendar Fehler

Ein CMSimple Support Forum für deutsch sprechende Nutzer und Entwickler
frase
Posts: 4034
Joined: Thu Apr 21, 2016 6:32 am
Location: Saxony
Contact:

Re: Plugin Calendar Fehler

Post by frase » Fri May 21, 2021 4:36 pm

Hm, ich habe gerade mal den Kalender mit einem Template aus Gerts "Wave"-Reihe getestet - alles funktioniert bei mir.
Am Template liegt es also wahrscheinlich nicht :(

Ich bin jetzt ratlos. Woran könnte es noch liegen?

frase
Posts: 4034
Joined: Thu Apr 21, 2016 6:32 am
Location: Saxony
Contact:

Re: Plugin Calendar Fehler

Post by frase » Fri May 21, 2021 4:51 pm

Im zweiten Bild von hier ist zu sehen, dass das Plugin "Calendar 1.4.8" aktiviert ist.
Sollte es nicht um "Calendar 2.1" gehen?

Wenn du mit den verschiedenen Versionen testest, dann genügt es, wenn du im Pluginverzeichnis einen Punkt [.] vor den Pluginnamen setzt, den du vorübergehend deaktivieren willst.
Danach die Seite mit Strg-F5 neu laden (nur Windows) oder den Browsercache gründlich leeren.

Motsch
Posts: 46
Joined: Tue Dec 10, 2019 10:18 am

Re: Plugin Calendar Fehler

Post by Motsch » Fri May 21, 2021 5:02 pm

Hallo,
ganz einfach, weil es damit (Version 1.4.8) funktioniert und mit der Version 2.1 kommt eben die Meldung siehe Anfang vom Thread.

Egal, dann eben kein Kalender ;-(

Gruß
motsch

SiNiTaSa
Posts: 109
Joined: Tue Jan 03, 2017 10:33 am
Location: BW|GERMANY

Re: Plugin Calendar Fehler

Post by SiNiTaSa » Fri May 21, 2021 7:23 pm

kenn mich auch nicht so aus mit php.......aber kann es sein, dass evtl. ein composer oder so auf dem Server installiert ist, mit einer Minimum Version"php": ">=5.6", ???
aka smaxle | plugin_XH 1.7

cmb
Posts: 13702
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin Calendar Fehler

Post by cmb » Fri May 21, 2021 9:56 pm

cmb wrote:
Fri May 21, 2021 3:21 pm
Es geht nicht um die CMSimple_XH Version, oder die Version des Plugin, sondern um die PHP. Die ist bei dir ziemlich sicher kleiner als PHP 7.0.0.
Zunächst einmal muss ich mich dafür entschuldigen; ich hätte mir den Screenshot anschauen sollen, der ja zeigt, dass PHP 7.4.14 verwendet wird. Verstehen tue ich das aber immer noch nicht, denn die Fehlermeldung bezieht sich offensichtlich auf das : string am Ende der Zeile, wo eben PHP 5 nur ein ; oder { erwartet, aber ab PHP 7 das : string erlaubt ist, siehe https://3v4l.org/7O02k.

Du kannst testweise das : string am Ende der Zeile entfernen; dann wird vermutlich der gleiche Fehler für Zeile 102 angezeigt. Falls ja, könntest du bitte unter Einstellungen → Info → PHP-Info einen Screenshot des Abschnitts mit dem ZendEngine-Logo (ziemlich oben auf der Seite) machen, und hier posten; sieht bei mir so aus:
Screenshot 2021-05-21 235056.gif
Ich vermute, dass bei dir noch die ein oder andere Zend-Erweiterung installiert ist, und dort aufgeführt wird; vielleicht liegt es daran.
You do not have the required permissions to view the files attached to this post.
Christoph M. Becker – Plugins for CMSimple_XH

Motsch
Posts: 46
Joined: Tue Dec 10, 2019 10:18 am

Re: Plugin Calendar Fehler

Post by Motsch » Tue May 25, 2021 11:37 am

Hallo Christoph,
sende mal diesen Screenshot von diesem gesamten "Ding" zend engine.
zendengine.JPG
Es ist aber noch die Calendar-Version 1.4.8 installiert.

Gruß
motsch
You do not have the required permissions to view the files attached to this post.

cmb
Posts: 13702
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin Calendar Fehler

Post by cmb » Tue May 25, 2021 4:55 pm

Danke für den Screenshot! Ich könnte mir vorstellen, dass etwas mit dem ionCube PHP Loader 10.4.0 nicht stimmt. Da wurden in der Zwischenzeit einige Bugs behoben (obwohl keiner der gelisteten nach diesem Problem ausschaut). Eine andere Erklärung für das seltsame Verhalten habe ich aber nicht.
Christoph M. Becker – Plugins for CMSimple_XH

olape
Posts: 1778
Joined: Fri Mar 13, 2015 8:47 am
Contact:

Re: Plugin Calendar Fehler

Post by olape » Tue May 25, 2021 5:22 pm

Motsch wrote:
Fri May 21, 2021 3:35 pm
bei all-inkl ist die Version 7.4 aktiv, zumindest wird das ist dieser Liste von PHP-Dateien angezeigt.
Vielleicht kannst du ja mal testweise auf 7.2 oder 7.3 stellen?
Oder auch die ganze Installation mal lokal mit xamp testen?

Allinkl hat (oder zumindest hatte, solange ich mit ihnen zu tun hatte) immer einen guten Support.
Vielleicht können die auch weiterhelfen.

Post Reply