php 5.4 chez hebergeur 1&1 - cmsimple 3.2 [Résolu]

Un forum de support CMSimple pour des utilisateurs et développeurs francophones

Moderator: Bob

Post Reply
scoubi47
Posts: 12
Joined: Thu Feb 26, 2009 3:25 pm

php 5.4 chez hebergeur 1&1 - cmsimple 3.2 [Résolu]

Post by scoubi47 » Fri Nov 30, 2012 11:03 pm

Bonsoir,
plusieurs de mes sites cmsimple en 3.2 sont hebergés chez 1&1 qui m'indiqe qu'il vont passer automoatiquement à la verion php 5.4 au 01 avril 2013 et que les versions de php antérieures ne seront plus supporter.

cmsimple 3.2 va t'il fonctionner sous php 5.4 ?

merci par avance pour vos renseignements,

cordialement,

cmb
Posts: 13273
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Passe en php 5.4 chez hebergeur 1&1 - cmsimple 3.2 ?

Post by cmb » Fri Nov 30, 2012 11:45 pm

Bonsoir Scoubi,
scoubi47 wrote:cmsimple 3.2 va t'il fonctionner sous php 5.4 ?
Je suis fermement le supposer.

Je sais que CMSimple 3.4 fonctionne bien sous PHP 5.4 (à l'exception d'un problème mineur).

Si vous utilisez des plugins, qui pourrait faire une différence.

Christoph
Christoph M. Becker – Plugins for CMSimple_XH

Bob
Posts: 120
Joined: Sat Jun 14, 2008 8:30 am
Location: France
Contact:

Re: Passe en php 5.4 chez hebergeur 1&1 - cmsimple 3.2 ?

Post by Bob » Sun Dec 02, 2012 4:23 pm

Bonjour
La version 3.2 de CMSimple est toujours compatible avec PHP 5.4 avec des erreurs qui peuvent s'afficher (notamment la fonction eregi dépréciée sous PHP 5). Mais le principal problème pourrait venir des failles de sécurité sur ces anciennes versions, failles que j'ai déjà vu exploitées sur certains sites.
La dernière version ANSI (iso 8859-1) basée sur CMSimple, donc la plus proche pour la mise à jour de vos sites est CMSimple_XH 1.1.6, compatible PHP 5.4 et sécurisée.
Mais avec une toute petite adaptation de votre contenu (UTF-8), et le remplacement des plugins si nécessaires, il est préférable de passer à la version 1.5.5 de XH ou la nouvelle version de CMSimple (4.x).
Bob

scoubi47
Posts: 12
Joined: Thu Feb 26, 2009 3:25 pm

Re: Passe en php 5.4 chez hebergeur 1&1 - cmsimple 3.2 ?

Post by scoubi47 » Wed Dec 05, 2012 9:18 pm

Bonsoir à tous,

merci pour vos conseils,

Il faut toujours penser à évoluer, je vais donc essayer d'installer la nouvelle version de cmsimpe 4.02 et faire des tests avec le contenu.

je vous tiens au courant

cordialement,

bonsoir,

en fin de compte je suis passé sur la version 1.5.5_xh, et elle est vraiment super par rapport à l'ancienne, avec le cryptage du mot de passe, les meta sur chaque page, plusieurs galaries photos sur la même page, et fonctionne trés bien avec php 5.4

merci encore

a + ;)

Bob
Posts: 120
Joined: Sat Jun 14, 2008 8:30 am
Location: France
Contact:

Re: php 5.4 chez hebergeur 1&1 - cmsimple 3.2 [Résolu]

Post by Bob » Tue Jul 02, 2013 4:29 pm

Je remonte le post parce qu'aux dernières nouvelles 1and1 ferait finalement la transition de ses serveurs vers PHP 5.4 en août 2013...
D'après mes tests les compatibilités avec CMSimple seraient les suivantes :

CMSimple_XH :
1.6.x -> compatible
1.5.x -> compatible
1.4.x -> non compatible en dessous de 1.4.4
1.3.x -> non compatible - non suivie
1.1.x -> non compatible en dessous de 1.1.6 (FCKeditor non compatible - Tinymce compatible)
CMSimple :
4.x -> compatible
3.x -> non compatible en dessous de 3.3

cmb
Posts: 13273
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: php 5.4 chez hebergeur 1&1 - cmsimple 3.2 [Résolu]

Post by cmb » Tue Jul 02, 2013 5:06 pm

Bob wrote:1.1.x -> non compatible en dessous de 1.1.6 (FCKeditor non compatible - Tinymce compatible)
FCKeditor devrait bien fonctionner sous PHP 5.4, sauf pour IE > = 9. Sinon, nous devrons envisager d'échanger FCKeditor dans CMSimple_XH 1.1.x avec TinyMCE ou abandonner le support de cette branche de sortie plus tôt que le 31 décembre.
Christoph M. Becker – Plugins for CMSimple_XH

Bob
Posts: 120
Joined: Sat Jun 14, 2008 8:30 am
Location: France
Contact:

Re: php 5.4 chez hebergeur 1&1 - cmsimple 3.2 [Résolu]

Post by Bob » Tue Jul 02, 2013 5:26 pm

nous devrons envisager d'échanger FCKeditor dans CMSimple_XH 1.1.x avec TinyMCE
C'est ce qu'il y aurait de plus simple à faire (et utile pour ceux qui ne souhaitent pas faire passer leur contenu d'ANSI vers UTF8), si quelqu'un peut confirmer que FCK pose des problèmes...

Post Reply