Plugins compatibility PHP7

General questions about CMSimple
Post Reply
bca
Posts: 288
Joined: Tue Sep 15, 2009 4:49 pm

Plugins compatibility PHP7

Post by bca » Tue Mar 20, 2018 12:49 pm

Hi
Just updated my site to 1.7.2 and everything works OK.
My ISP upgraded the server to PHP 7 (from 5.6) which broke the site. He has since downgraded for me for a while to troubleshoot.

I assume CMS 1.7.2 is compatible with PHP 7 so it is probably one of the plugins.

Does anyone know if any of these are incompatible:
Advancedform, Coco, codeeditor, fa,slideshow, templateswitch, video

B

cmb
Posts: 12940
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugins compatibility PHP7

Post by cmb » Tue Mar 20, 2018 1:12 pm

bca wrote:
Tue Mar 20, 2018 12:49 pm
I assume CMS 1.7.2 is compatible with PHP 7 so it is probably one of the plugins.

Does anyone know if any of these are incompatible:
Advancedform, Coco, codeeditor, fa,slideshow, templateswitch, video
Which version of Templateswitch? I assume that current versions are not compatible with CMSimple_XH at all, and older versions might not be compatible with PHP 7.

However. there also might an incompatibility with the core, maybe related to some (un)available PHP extensions or some particular settings.

It might be best to switch to PHP 7 again, and to enable debug mode, which is supposed to report the relevant problem. If your Webspace is configured to show a 500 error page, you'd have to investigate the PHP error log.

Also note, that Coco_XH is still not compatible with CMSimple_XH 1.7.
Christoph M. Becker –Plugins for CMSimple_XH

bca
Posts: 288
Joined: Tue Sep 15, 2009 4:49 pm

Re: Plugins compatibility PHP7

Post by bca » Tue Mar 20, 2018 1:54 pm

Thanks Christof.
It was one of those. I deleted them both and it now works OK.

I didnt mean to include coco in the list as i had already commented it out in the template but hadn't deleted it from the server.

B

Post Reply