ajaxfilemanager drives me nuts (Tiny MCE)

Questions about how to use the online - editors and suggestions how to improve them
Post Reply
svasti
Posts: 1649
Joined: Wed Dec 17, 2008 5:08 pm

ajaxfilemanager drives me nuts (Tiny MCE)

Post by svasti » Tue Apr 07, 2009 9:15 pm

Hallo respected experts!

I am new to CMSimple, and I find that here are very nice people helping each other!

I have already made several CMSimple installations and have written a plugin which you can find in the wiki (Quoteoftheday) .
Tiny MCE with Ajaxfilemanager (put together by Klaus Treichler) is my preferred editor.

Now, on a new website the Ajax filemanager doesn't work as expected. On the same server I have another CMSimple implemantation were it works. I had quite some email exchanges with the provider. He says, server implementation is identical. Php-info also gives same results for both websites (exept for session cookies).

Now, to check, I uploaded exactly the same CMSimple installation on both websites. One works, the other doesn't.

The problem is as follows:
If you use TinyMCE, to insert an image you click the image icon and the "image window" opens. In that window you can click the ajax filemanager which will show the images. You select an image, the ajax filemanager closes, and in the "image window" shows the address of the image.

And here is the problem. In one installation the image address is correct:

http://test.closertoyourself.de/images/indus.jpg

but in the problematic installation the image address given is not correct:

http://www.integralvoice.de/home/www/web58/html/test/images/indus.jpg

This address of course doesn't work. No image will show on the Page. home/www/web58/html/test/ should not be there. This is the address from the root server.

What to do now? May be a line of code has to be changed in the ajaxfilemanager.php?

Is there somewhere in the CMSimple family a knowledgable soul, who can help? That would be fantastic.

frank z

CMSimple-Styles.com
Posts: 342
Joined: Thu Jun 26, 2008 8:19 pm
Location: Germany
Contact:

Re: ajaxfilemanager drives me nuts (Tiny MCE)

Post by CMSimple-Styles.com » Wed Apr 08, 2009 11:38 pm

I also had this bug with this, so i changed a little bit of stuff but i cant really remember what it was. This is included in my CMSimple SE. You can download it at CMSimple-Styles.com. Please try this one maybe it works.

svasti
Posts: 1649
Joined: Wed Dec 17, 2008 5:08 pm

Re: ajaxfilemanager drives me nuts (Tiny MCE)

Post by svasti » Thu Apr 09, 2009 12:17 pm

Hallo Jens,
I am actually using your CMSimple SE, which I find is really an improvement on the standard edition. And the original plugin of Klaus Treichler also didn't work for me, but your implementation worked. This is a good occasion to thank you for your work!

I think, the bug has something to do with cookies, as cookies are used to ensure that the ajaxmanager cannot be used by hackers.

frank z

svasti
Posts: 1649
Joined: Wed Dec 17, 2008 5:08 pm

Re: ajaxfilemanager drives me nuts (Tiny MCE)

Post by svasti » Thu Sep 16, 2010 2:12 pm

Problem solved!
On this same problematic account I installed CMSimple_XH1.2 and again, the filemanager didn't work. Finally I went into the code to find the reason:

in sitelink.php there are references like "../../../../" and this gives a problem, if the php-security of the site is too restrictive.

On the server my CMSimple was located:
home/www/web58/html/CMSimple
but access to web58 was not allowed.

All the problems were gone, when I changed the installation to
home/www/web58/html/start/cms/CMSimple

I thought this may help somebody who may face similar problems

Post Reply